Windows Service

About the programming interface for the virtual PDF printer driver.

Moderator: jr

Windows Service

Postby mikko » Tue May 26, 2009 12:21 pm

I can't get the Bullzip to use the settings created using PDFPrinterSettings when running my application as a Windows Service. It creates the settings to "C:\Documents and Settings\LocalService\Bullzip\PDF Printer\runonce@Bullzip PDF Printer.ini" but when the print is executed it uses default settings and that created ini does not get deleted. It does not matter where the ini is located, it still uses the default settings. I tried copying the file to multiple places (including c-root, system root, system32, application data folder, etc.) I can however get it to work if I run my application as a normal application (not as service). Bullzip then creates the settings to "C:\Documents and Settings\mikko\Application Data\Bullzip\PDF Printer\runonce@Bullzip PDF Printer.ini".

I was hoping I could use the default settings ini for this, but it seems (at least reading it from the documentations) that there is no keyword for the document path? Something like this:
[PDF Printer]

Can someone help me please?
Posts: 2
Joined: Tue May 26, 2009 12:03 pm

Re: Windows Service

Postby rozeboosje » Mon Jun 08, 2009 4:16 pm

I have just posted a similar issue myself. It's still awaiting approval by a moderator, but I am using the PDF Printer from a service. It appears to be working fine except for the very first time it tries to interact with the desktop no matter how much I tell it to "Shut Up" ;-)

I'm using the COM interface.
Posts: 3
Joined: Thu Jun 04, 2009 12:44 pm

Re: Windows Service

Postby mikko » Wed Jun 10, 2009 8:29 am

Using the settings (all others but the "output" parameter) in the first example, you won't get any interaction from Bullzip PDF Printer. You will however get a short blink of a window from Windows Printer Spooler. I don't know if it's possible to disable that window from popping up in Windows?

I got my problem solved by installing the Service using my own credentials. Still, I hope it would be possible to "fix" the problem in the first post I am having. :)
Posts: 2
Joined: Tue May 26, 2009 12:03 pm

Return to Programming

Who is online

Users browsing this forum: No registered users and 1 guest